gizmo_thunder home

Help us Help you :)

Posted on 2005/09/16 04:56
Plz tell us if you could not run our game...
and do mention your system details. 
once again the requirements of our game are
python 2.4
pyopengl
pygame
pil(python image library)
thank you :)
Add comment