Richard Jones' Log: HTPC update

Fri, 16 Sep 2005

It's been a while since the last HTPC update. After that post, I'd actually given up and turned the thing into my new desktop machine. The uber video card I own didn't fit in the case so well, but I did get it going ;)

Anyway, we now have a new TV which sports VGA and DVI inputs. Aha! No more relying on the TV-Out (which as far as I know still isn't fixed in the Unichrome drivers). I duly re-purpose the machine as HTPC again, and reinstall all the bits I need. Unfortunately, the IRQ cascade problem I ran into last time has just gotten worse, and the on-board VGA is uselessly slow. A crappy second-hand video card (with DVI output) later, and I'm now plugged into the TV.

Now, the TV docs say it's got a resolution of 1360x768 pixels, but there's no info on refresh rates. I know it does basic VESA modes, as a 1024x768x60 mode works. I spent about an hour trying to figure the modeline for a 1360x768 display, only to be told each time by the TV that the display was out of range. In desperation, I decided to go back to modes that I knew worked and then work up to 1360 from there, so I enabled a standard 1280x768 mode. Worked fine on the TV ... except the TV reports it as 1360x768. No amount of modeline tweaking can get a stable 1360-wide display, so I'm just sticking with 1280-wide and a slight display stretching.

From there, I've just been slowly configuring up MythTV. Got sound working (including pass-through of AC3 decoding on the optical audio link), DVDs play, and do wide-screen just fine (if the DVD is encoded correctly, hurm), our music collection is on there and playing. I can tune TV manually with xine, but haven't managed to configure MythTV to show TV yet. So almost there...

Comment by Toby on Fri, 16 Sep 2005

Don't suppose you can install windows and see if that can drive the strange display resolution? It's pretty embarrassing that X still needs modelines. Are you sure it actually does? It's *supposed* to get everything from EDID. Maybe your TV (documentation) is lying to you?

Comment by Richard on Fri, 16 Sep 2005


Although my laptop was plugged into a projector the other night and it reported two modes: 800x600 and 2304x1786. Needless to say, the latter did not work, and manually selecting 1024x768 did work.